Need OSX help

Help center. Members helping members
Forum rules
Ibexes
Member
Posts: 1
Joined: June 2nd, 2017
Reputation: 0

Need OSX help

Postby Ibexes » Fri Jun 02, 2017 6:25 pm

Okay, so I'm not sure if FOF is still supported on OSx.

I've installed v1.3.110 as recommended by the mac users post, along with others. I keep running into an error

Code: Select all

ImportError: PyObjC 1.2 or later is required to use pygame on Mac OS X. http://pygame.org/wiki/PyObjC
. I have installed this PyObjC module, the entire pygame thing for both python2 and 3... I've installed so much crap I can't even keep track anymore. And yes, I'm sure I've installed pygame correctly.

Code: Select all

sudo pip2.7 install -I pyobjc
installs without error.

I've also tried to run the RF-mod 4.15, but I run into this

Code: Select all

error: Failed to start CoreAudio: AudioUnitSetProperty (kAudioUnitProperty_SetInputCallback)
.

I'm running OS sierra 10.12.4.

Any help would be appreciated, any response would be appreciated, even if it's this has been depreciated. Might be missing information but I'm not really sure what else to give, so just ask.

Thanks all.
crayne777
Member
Posts: 2
Joined: August 17th, 2017
Reputation: 0
Contact:

Re: Need OSX help

Postby crayne777 » Thu Aug 17, 2017 11:24 am

I got the same problem. did you solve it?
User avatar
Hellrock120
Member
Posts: 110
Joined: March 21st, 2015
Reputation: 82
Contact:

Re: Need OSX help

Postby Hellrock120 » Thu Aug 17, 2017 9:55 pm

Hey guys, try with Phase Shift instead, it works basically the same as FoF and has a better interface.
crayne777
Member
Posts: 2
Joined: August 17th, 2017
Reputation: 0
Contact:

Re: Need OSX help

Postby crayne777 » Mon Aug 21, 2017 1:15 pm

Phase Shift is not available for Mac OS X unfortunately :/
Linkid
Member
Posts: 5
Joined: July 6th, 2015
Reputation: 0

Re: Need OSX help

Postby Linkid » Sun Sep 10, 2017 8:44 am

Hi Ibexes.
Did you try FoFiX (https://github.com/fofix/fofix) ? I would like to know if it's working on OSX 'cause I'm working on it.
Ruler of Chatrooms
User avatar
nobby76
Member
Posts: 3899
Joined: August 29th, 2006
Location: Just off the coast of Saturn
Reputation: 7

Re: Need OSX help

Postby nobby76 » Tue Sep 12, 2017 11:16 am

Hellrock120 wrote:Hey guys, try with Phase Shift instead, it works basically the same as FoF and has a better interface.

crayne777 wrote:Phase Shift is not available for Mac OS X unfortunately :/


And that is the exact reason we DO NOT just blindly tell people " Use phase shift / Fofix" to try and fix a problem. If you cant offer help to the actual problem then dont respond, if you do, you are answering something he did not ask about..
Image
LONG LIVE THE NOOBS, THEY WILL OVER THROW US WITH THERE VASTLY SUPERIOR STUPIDITY.
Check out the Tutorial Making songs without having to fret a single note And come check out the IRC Chatroom
Linkid
Member
Posts: 5
Joined: July 6th, 2015
Reputation: 0

Re: Need OSX help

Postby Linkid » Thu Sep 14, 2017 5:19 am

@nobby76: FoFiX is based on FoF, with some bug fixes. So if running FoF under OSX is broken, maybe the issue is solved with FoFix.

@Ibexes: About the error, which version of PyObjc are you using ? If you used your command line, it should be the lastest version available in PyPi. And then, you're using a newer version than you should…
After uninstalling your PyObjc package (with uninstall), try to install PyObjc 1.2 (not available in PyPi):

Code: Select all

sudo pip2.7 install https://bitbucket.org/ronaldoussoren/pyobjc/get/pyobjc-1.2.tar.gz

Return to “Tech Support”

Who is online

Users browsing this forum: No registered users and 2 guests