Tutorial: How to use the Wii Guitar for FoF - Really works! Pics as well!

FOF discussion only. Do NOT post help questions here!
The Wiitard
User avatar
rednano12
Member
Posts: 1549
Joined: December 22nd, 2007
Location: http://www.youtube.com/watch?v=failedRickRoll
Reputation: 0
Contact:

Postby rednano12 » Tue Jan 01, 2008 10:19 am

Last edited by rednano12 on Thu May 15, 2008 4:32 pm, edited 1 time in total.
Oct. 30th is Cama appreciation day!

Check out my first song: Snow (Hey Oh)
A bit sleepy
User avatar
Kotti
Member
Posts: 2860
Joined: March 23rd, 2007
Location: Finland
Reputation: 0
Contact:

Postby Kotti » Tue Jan 01, 2008 10:40 am

Thanks, I've been thinking of using my Wii guitar, but I've always been too lazy to read the guides.

Seems to be working, even though my PC started writing "qqqqqqq" after starting GlovePIE. I had to restart my computer, even removing Bluetooth-dongle and keyboard didn't help :p
Last edited by Kotti on Tue Jan 01, 2008 1:19 pm, edited 1 time in total.
Image
Image
The Wiitard
User avatar
rednano12
Member
Posts: 1549
Joined: December 22nd, 2007
Location: http://www.youtube.com/watch?v=failedRickRoll
Reputation: 0
Contact:

Postby rednano12 » Tue Jan 01, 2008 1:37 pm

65 views and no replies!
I enjoy feedback... :D
Oct. 30th is Cama appreciation day!



Check out my first song: Snow (Hey Oh)
The Wiitard
User avatar
rednano12
Member
Posts: 1549
Joined: December 22nd, 2007
Location: http://www.youtube.com/watch?v=failedRickRoll
Reputation: 0
Contact:

Postby rednano12 » Tue Jan 01, 2008 1:39 pm

Kotti wrote:Thanks, I've been thinking of using my Wii guitar, but I've always been too lazy to read the guides.

Seems to be working, even though my PC started writing "qqqqqqq" after starting GlovePIE. I had to restart my computer, even removing Bluetooth-dongle and keyboard didn't help :p

It started writing Q on what program? The debug menu?
Is your Dongle compatible? Can you describe in more detail?
Oct. 30th is Cama appreciation day!



Check out my first song: Snow (Hey Oh)
User avatar
CosmoKramer
Member
Posts: 27
Joined: November 11th, 2007
Reputation: 0

Postby CosmoKramer » Tue Jan 01, 2008 1:47 pm

Hi..Thanks for this..Much appreciated...I'm just having a little problem...I successfully connected my Wiimote to my computer with a Kensington Bluetooth dongle(which is in the compatibility list)...I downloaded GlovePie and input your script, and ran it...I mapped the buttons, as in the script..But when i test the keys, nothing happens...What can be wrong? Also, when connected to the pc, should the blue lights be constantly flashing? Please help..Thanks alot
The Wiitard
User avatar
rednano12
Member
Posts: 1549
Joined: December 22nd, 2007
Location: http://www.youtube.com/watch?v=failedRickRoll
Reputation: 0
Contact:

Postby rednano12 » Tue Jan 01, 2008 1:54 pm

CosmoKramer wrote:Hi..Thanks for this..Much appreciated...I'm just having a little problem...I successfully connected my Wiimote to my computer with a Kensington Bluetooth dongle(which is in the compatibility list)...I downloaded GlovePie and input your script, and ran it...I mapped the buttons, as in the script..But when i test the keys, nothing happens...What can be wrong? Also, when connected to the pc, should the blue lights be constantly flashing? Please help..Thanks alot

The lights should stop after a little bit. When the script runs, it should stop the flashing and turn on the 1st LED. This same thing has happened to me a few times. Just restart :)
Oct. 30th is Cama appreciation day!



Check out my first song: Snow (Hey Oh)
User avatar
CosmoKramer
Member
Posts: 27
Joined: November 11th, 2007
Reputation: 0

Postby CosmoKramer » Tue Jan 01, 2008 1:58 pm

What should i restart? Should I re-sync the WiiMote to my pc or should i restart glovepie?
The Wiitard
User avatar
rednano12
Member
Posts: 1549
Joined: December 22nd, 2007
Location: http://www.youtube.com/watch?v=failedRickRoll
Reputation: 0
Contact:

Postby rednano12 » Tue Jan 01, 2008 2:17 pm

CosmoKramer wrote:What should i restart? Should I re-sync the WiiMote to my pc or should i restart glovepie?

Sorry for not being clear. I meant to restart the computer. :D
Oct. 30th is Cama appreciation day!



Check out my first song: Snow (Hey Oh)
User avatar
CosmoKramer
Member
Posts: 27
Joined: November 11th, 2007
Reputation: 0

Postby CosmoKramer » Tue Jan 01, 2008 2:37 pm

Great, that worked...Thanks again for this..
User avatar
ghen
Member
Posts: 80
Joined: December 27th, 2007
Location: Delaware
Reputation: 0
Contact:

Postby ghen » Tue Jan 01, 2008 10:45 pm

Most of the problems I've had connecting the wiimote to the computer are due to bluetooth. Sometimes it will pair up just fine and then just cut out when the lights stop flashing. Other times it works great. /shrug. Have you noticed any difficulties keeping the initial connection? if I get it connected to where the first blue light stays on then it stays connected all night.
The Wiitard
User avatar
rednano12
Member
Posts: 1549
Joined: December 22nd, 2007
Location: http://www.youtube.com/watch?v=failedRickRoll
Reputation: 0
Contact:

Postby rednano12 » Wed Jan 02, 2008 9:04 am

ghen wrote:Most of the problems I've had connecting the wiimote to the computer are due to bluetooth. Sometimes it will pair up just fine and then just cut out when the lights stop flashing. Other times it works great. /shrug. Have you noticed any difficulties keeping the initial connection? if I get it connected to where the first blue light stays on then it stays connected all night.

Same here. This whole process took me a week to figure out due to all of the bluetooth issues. Restart frequently. The Bluetooth seems to kind of fix itself once you restart.
Oct. 30th is Cama appreciation day!



Check out my first song: Snow (Hey Oh)
A bit sleepy
User avatar
Kotti
Member
Posts: 2860
Joined: March 23rd, 2007
Location: Finland
Reputation: 0
Contact:

Postby Kotti » Wed Jan 02, 2008 9:05 am

rednano12 wrote:It started writing Q on what program? The debug menu?
Is your Dongle compatible? Can you describe in more detail?

I think it was only that once, maybe I was holding Q when I connected Wiimote. It was quite funny actually. My friend asked something on Messenger and all I cuold answer was qqq.
Image
Image
The Wiitard
User avatar
rednano12
Member
Posts: 1549
Joined: December 22nd, 2007
Location: http://www.youtube.com/watch?v=failedRickRoll
Reputation: 0
Contact:

Postby rednano12 » Wed Jan 02, 2008 9:21 am

lol it presses q if you press - or shake the guitar. You must have 1 sensitive wiimote!
Last edited by rednano12 on Wed Jan 02, 2008 9:22 am, edited 1 time in total.
Oct. 30th is Cama appreciation day!



Check out my first song: Snow (Hey Oh)
User avatar
iolaus2563
Member
Posts: 7
Joined: January 3rd, 2008
Location: Cardiff
Reputation: 0
Contact:

Postby iolaus2563 » Thu Jan 03, 2008 12:00 pm

This is a great script. Thanks very much. I haven't got to test it yet as I am currently out of reach of my wii (its back at uni) but I will definitely use this when I get back there.
Redth
Member
Posts: 4
Joined: March 14th, 2007
Reputation: 0

Postby Redth » Fri Jan 04, 2008 9:46 am

I just tried this last night (I happened to look up FoF again the other day after I hadn't kept up with the community for months, and found out there was some new RF-mod stuff that would get me interested again).

Anyways, worked very easily for me. I loaded up BlueSoleil for my Belkin Bluetooth dongle, and connected nearly immediately. Now, at first, my wiimote would just still sit flashing all LED's even though it seemed to be 'paired'. I walked out of the room for a couple minutes, came back and it was lit up as player 1 LED, which was what I wanted.

GlovePIE works nice, though I think I'm going to alter that script a bit. I'd like to use up/down as the strum bar and try and make the interface a bit more similar to GH. I'll post the changes I've made to the script when I'm done.

Return to “General FOF Discussion”

Who is online

Users browsing this forum: No registered users and 3 guests