REPORT NEW ERRORS HERE - Wiki-Joint Project

Help center. Members helping members
Forum rules
Shredder
jake2k3
Member
Posts: 2801
Joined: February 24th, 2007
Location: River City, Alabama
Reputation: 0

Postby jake2k3 » Thu Jan 10, 2008 9:42 pm

Hey all,
I've recently noticed that the FoFWiki page on error messages isn't exactly all that helpful unless you are getting a common error. So, I've decided to start up a list of errors not listed on the wiki-page.

Edit(BlackFate):
[size=180]If you have an error, and it IS NOT listed on the FoF-Wiki Page of Error Messages, post it here.[/size]

=============================================================

[size=150]1. If you post in this thread and it doesn't have an error such as below, then you will get a warning.[/size]

[size=150]2. If you post in this thread and it has an error that we already know about, then you will get a warning.[/size]

=============================================================

If you report an error that has already been listed either here or the wiki it will be flagged for deletion. If you have a thread about the error already in Tech Support please leave the link to that as well.

As errors are reported and have been solved (and the method is confirmed as a way to solve the error) it will be crossed off the list and added to the wiki page. Hopefully this will be a good way to make Tech Support more effecient by adding an area for people to report new problems about the game, or old problems that have just never been documented.

A few guidlines to error reporting. Please give us a description of what happens and the traceback report (see wiki page for details). Do not post lagging problems here, this is for strictly errors only. Not all errors give traceback reports; in this situation please explain the error as well as you can and if you get a pop-up dialog box when FoF closes please take a screenshot and post it with your report.

Current Unsolved Errors
Report Format
-Reporter:
-Version (if known):
-Status:
Traceback:
Thread(s):

---
-Subzero Heat
-Version: Unknown
-Status: Unsolved
Traceback (most recent call last):
File GameEngine.py, line 388, in run
File GameEngine.py, line 380, in main
File "View.pyo", line 208, in render
File GuitarScene.py, line 1175, in render
File "Scene.pyo", line 285, in render
File GuitarScene.py, line 791, in render3D
UnboundLocalError: local variable 'i' referenced before assignment

http://www.fretsonfire.net/cgi-bin....d174374
---

---
-Jamiez
-Version: 1.2.451
-Status: Unsolved
Traceback (most recent call last):
File "FretsOnFire.py", line 77, in ?
File "GameEngine.pyo", line 197, in
File "View.pyo", line 64, in
ZeroDivisionError: float division

http://www.fretsonfire.net/cgi-bin....77;st=0
---

---
-vonnecht
-Version: 1.2.451 & 1.2.512
-Status: Unsolved
Traceback (most recent call last):
File "FretsOnFire.py", line 94, in ?
File "GameEngine.pyo", line 183, in
File "Video.pyo", line 49, in setMode
pygame.error: DirectInputCreate: Undefined error!

http://www.fretsonfire.net/cgi-bin/ikonboard.cgi?act=ST;f=3;t=16664
---

---
-Crash401
-Version: Unknown
-Status: Unsolved
Traceback (most recent call last):
File "FretsOnFire.py", line 36, in ?
File "GameEngine.pyo", line 28, in ?
File "Engine.pyo", line 25, in ?
File "Network.pyo", line 23, in ?
File "asyncore.pyo", line 51, in ?
File "socket.pyo", line 45, in ?
File "_socket.pyo", line 12, in ?
File "_socket.pyo", line 10, in __load
ImportError: WSAStartup failed: error code 1010

http://www.fretsonfire.net/cgi-bin/ikonboard.cgi?act=ST;f=3;t=16672
---

---
-Masterincs
-Version: 1.2.451
-Status: Unsolved
Traceback (most recent call last):
File "GameEngine.pyo", line 346, in run
File "GameEngine.pyo", line 336, in main
File "Engine.pyo", line 139, in run
File "Engine.pyo", line 130, in _runTask
File "Server.pyo", line 70, in run
File "Network.pyo", line 225, in communicate
File "asyncore.pyo", line 122, in poll
error: (10038, 'An operation was attempted on something that is not a socket')

http://www.fretsonfire.net/cgi-bin/ikonboard.cgi?act=ST;f=3;t=16397;
---

---
-3nish
-Version: 1.1.324
-Status: Unsolved
Traceback (most recent call last):
File "GameEngine.pyo", line 350, in run
File "GameEngine.pyo", line 340, in main
File "Engine.pyo", line 113, in run
File "Engine.pyo", line 104, in _runTask
File "Resource.pyo", line 203, in run
File "Resource.pyo", line 92, in load
File "Dialogs.pyo", line 331, in <lambda>
File "Song.pyo", line 1013, in getAvailableSongs
File "Song.pyo", line 110, in
File "Cerealizer.pyo", line 599, in loads
File "Cerealizer.pyo", line 172, in undump
File "Cerealizer.pyo", line 321, in undump_obj
File "Cerealizer.pyo", line 205, in undump_ref
ValueError: Unknown ref code ''!

http://www.fretsonfire.net/cgi-bin/ikonboard.cgi?act=ST;f=3;t=16274
---

---
-Santtu
-Version: Unknown
-Status: Possibly Solved
Traceback (most recent call last):
File "FretsOnFire.py", line 69, in ?
File "GameEngine.pyo", line 179, in
File "Video.pyo", line 68, in setMode
pygame.error: Unable to reset window for OpenGL context

http://www.fretsonfire.net/cgi-bin/ikonboard.cgi?act=ST;f=3;t=11896
---

---
-rat_dot_exe
-Version: Unknown
-Status: Solved, Unconfirmed
Traceback (most recent call last):
File "GameEngine.pyo", line 346, in run
File "GameEngine.pyo", line 338, in main
File "View.pyo", line 183, in render
File "MainMenu.pyo", line 189, in render
File "Svg.pyo", line 606, in draw
GLerror: [Errno 1280] invalid enumerant

http://www.fretsonfire.net/cgi-bin/ikonboard.cgi?act=ST;f=3;t=7317
---

---
-Momentosis
-Version: Unknown
-Status: Solved, Uncomfirmed
Traceback (most recent call last):
File "GameEngine.pyo", line 373, in run
File "GameEngine.pyo", line 365, in main
File "View.pyo", line 208, in render
File "GuitarScene.pyo", line 840, in render
AttributeError: GuitarSceneClient instance has no attribute 'lastEvent'

http://www.fretsonfire.net/cgi-bin/ikonboard.cgi?act=ST;f=3;t=11545
---

---
-Demaster
-Version: Unknown
-Status: Unsolved
Traceback (most recent call last):
File "GameEngine.pyo", line 346, in run
File "GameEngine.pyo", line 320, in loading
File "View.pyo", line 183, in render
File "Dialogs.pyo", line 257, in render
File "Svg.pyo", line 609, in draw
GLerror: [Errno 1283] stack overflow

http://www.fretsonfire.net/cgi-bin/ikonboard.cgi?act=ST;f=3;t=10513
---

---
-Fiddlefaddle
-Version: Unknown
-Status: Unsolved
Traceback (most recent call last):
File "Session.pyo", line 66, in signalMessage
File "Session.pyo", line 87, in handleMessage
File "World.pyo", line 245, in handleSceneCreated
File "SceneFactory.pyo", line 40, in create
File "Scene.pyo", line 222, in
TypeError: createClient() got an unexpected keyword argument 'libraryName'

http://www.fretsonfire.net/cgi-bin/ikonboard.cgi?act=ST;f=3;t=10391
---

---
-Radihimi
-Version: Unknown
-Status: Unsolved
Traceback (most recent call last):
File "FretsOnFire.py", line 64, in ?
File "GameEngine.pyo", line 155, in
File "Video.pyo", line 49, in setMode
pygame.error: DirectInputDevice::SetCooperativeLevel: Unknown DirectInput error: 0x80004001

http://www.fretsonfire.net/cgi-bin/ikonboard.cgi?act=ST;f=3;t=8203
---

---
-Asmodai100
-Version: Unknown
-Status: Unsolved
Traceback (most recent call last):
File "FretsOnFire.py", line 64, in ?
File "GameEngine.pyo", line 143, in
File "Engine.pyo", line 36, in
File "Timer.pyo", line 28, in
ZeroDivisionError: integer division or modulo by zero


http://www.fretsonfire.net/cgi-bin/ikonboard.cgi?act=ST;f=3;t=7988
http://www.fretsonfire.net/cgi-bin/ikonboard.cgi?act=ST;f=3;t=1269
---

If you have ANY information on how to solve these, please help out the user in their thread. THIS THREAD IS NOT TO BE USED FOR HELPING TO SOLVE ERRORS. This thread is for reporting errors ONLY.

Please help us out!
~Jake2k3
Last edited by BlackFate on Sun Apr 27, 2008 11:01 am, edited 1 time in total.
Goodbye everyone. It's been fun. I spent many many hours here on these boards and playing/contributing to FoF. Today I uninstalled my game and deleted all my files. I just don't have the time or interest anymore. I won't be coming back here anymore. I might show up in the IRC from time to time to chat. I regret nothing.

So long, farewell.
~Jake2k3
Mass Effect FTW :)
User avatar
BlackFate
Member
Posts: 5272
Joined: October 9th, 2006
Location: From Wales, now in Sheffield
Reputation: 0

Postby BlackFate » Fri Jan 11, 2008 4:17 am

Glad I could help :) ,

Topic Pinned aswell, as it may help.

Mike.
Last edited by BlackFate on Sat Jan 12, 2008 6:41 am, edited 1 time in total.
Image
Image
Songs Finished: 82,
Metallica - Papa Roach - Disturbed - Bloodhound Gang
Ruler of Chatrooms
User avatar
nobby76
Member
Posts: 3904
Joined: August 29th, 2006
Location: Just off the coast of Saturn
Reputation: 7

Postby nobby76 » Fri Jan 11, 2008 10:10 am

HOLY HELL BLACKFATE!! your like some sort of FOF error genie.
Rub your hard drive 3 times and blackfate pops out shouting " update your graphix drivers" then gives you a warning :) Not 3 wishes
Image
LONG LIVE THE NOOBS, THEY WILL OVER THROW US WITH THERE VASTLY SUPERIOR STUPIDITY.
Check out the Tutorial Making songs without having to fret a single note And come check out the IRC Chatroom
Mass Effect FTW :)
User avatar
BlackFate
Member
Posts: 5272
Joined: October 9th, 2006
Location: From Wales, now in Sheffield
Reputation: 0

Postby BlackFate » Fri Jan 11, 2008 4:11 pm

nobby76 wrote:HOLY HELL BLACKFATE!! your like some sort of FOF error genie.
Rub your hard drive 3 times and blackfate pops out shouting " update your graphix drivers" then gives you a warning :) Not 3 wishes

LOL :D :cool: .

Mike.
Image
Image
Songs Finished: 82,
Metallica - Papa Roach - Disturbed - Bloodhound Gang
Shredder
jake2k3
Member
Posts: 2801
Joined: February 24th, 2007
Location: River City, Alabama
Reputation: 0

Postby jake2k3 » Fri Jan 11, 2008 7:07 pm

Thank you SO much Blackfate. That was incredible the amount of errors you put up to kick this thing off. I've added all of them to the list, so if you want to delete them off your post for the sake of cleaning up the topic that'd be great.

Again, thanks very much for all of them. The one concerning the "Invalid Enumerate" though, you had posted the wrong link (it was actually the link to the error above it). I went and found a similar thread, but don't believe it was the same you found.

Everyone, please continue to post any new errors you see come up.
~Jake2k3
Goodbye everyone. It's been fun. I spent many many hours here on these boards and playing/contributing to FoF. Today I uninstalled my game and deleted all my files. I just don't have the time or interest anymore. I won't be coming back here anymore. I might show up in the IRC from time to time to chat. I regret nothing.

So long, farewell.
~Jake2k3
Lin
Member
Posts: 158
Joined: December 21st, 2007
Location: Gilbert, Arizona
Reputation: 0
Contact:

Postby Lin » Fri Jan 11, 2008 10:30 pm

Well, I think I figured out the answer for this one.
Masterincs:

Error: (10038, 'An operation was attempted on something that is not a socket')

File "Server.pyo", line 70, in run

File "Network.pyo", line 225, in communicate

He did something that connects through a server and Network, so he should try running offline. Either that or something with online connection sent something that wasn't a packet. So he'd have to edit a packet that's trying to be sent in Server or Network.
My Songs:
Yellowcard - Way Away
Poison - Fallen Angel
Twisted Sister - I Wanna Rock
Thin Lizzy - Emerald
Judas Priest - Judas Rising

Drum player (Very good), Guitar player (Ok),Bass Player (W/e), Keyboard Player (Wtf?)
Shredder
jake2k3
Member
Posts: 2801
Joined: February 24th, 2007
Location: River City, Alabama
Reputation: 0

Postby jake2k3 » Sat Jan 12, 2008 1:03 am

We suggested he turn his firewall off but that didn't help. The last thing I suggested on that one was that he try turning "upload scores" off. He never replied.

Again, unless you have a definate fix for the problem (let's say, you had the same error and know a definate solution), try to limit suggestion posts in the error's thread. It'll be more helpful to them, and make the topic a better reference when we do add the error to the wiki.

Glad to see you're willing to help, though :)
~Jake2k3
Goodbye everyone. It's been fun. I spent many many hours here on these boards and playing/contributing to FoF. Today I uninstalled my game and deleted all my files. I just don't have the time or interest anymore. I won't be coming back here anymore. I might show up in the IRC from time to time to chat. I regret nothing.

So long, farewell.
~Jake2k3
Rogue_F
Member
Posts: 1504
Joined: November 2nd, 2006
Reputation: 1

Postby Rogue_F » Tue Jan 22, 2008 12:47 pm

You also should include which version they are using to the entry. Things vary greatly depending on the version (also it can help by looking at source lines, but only if you know what version it's for)

-Alex
Shredder
jake2k3
Member
Posts: 2801
Joined: February 24th, 2007
Location: River City, Alabama
Reputation: 0

Postby jake2k3 » Fri Jan 25, 2008 5:33 pm

Rogue_F wrote:You also should include which version they are using to the entry.

-Alex

Done for the errors where we know their version. The others are listed as "Unknown"
~Jake2k3
Goodbye everyone. It's been fun. I spent many many hours here on these boards and playing/contributing to FoF. Today I uninstalled my game and deleted all my files. I just don't have the time or interest anymore. I won't be coming back here anymore. I might show up in the IRC from time to time to chat. I regret nothing.

So long, farewell.
~Jake2k3
RatedRGuitar
Member
Posts: 3
Joined: March 23rd, 2007
Reputation: 0

Postby RatedRGuitar » Fri Jan 25, 2008 10:35 pm

My Frets on Fire won't start. It used to run fine, but I've recently reinstalled it, and now it won't run. It gives a pop up box that says Error, please check the log file for more details and it has this, over and over.

Traceback (most recent call last):
File "FretsOnFire.py", line 69, in ?
File "GameEngine.pyo", line 225, in
File "Data.pyo", line 48, in
File "Data.pyo", line 97, in loadSvgDrawing
File "Svg.pyo", line 556, in convertToTexture
File "Svg.pyo", line 108, in getRenderingQuality
AttributeError: GOpenGLBoard instance has no attribute 'RenderingQuality'

How can I fix this?
Shredder
jake2k3
Member
Posts: 2801
Joined: February 24th, 2007
Location: River City, Alabama
Reputation: 0

Postby jake2k3 » Sat Jan 26, 2008 2:43 pm

@RatedRGuitar:

I just PM'ed freelancer75 who had the same problem as you. this is what he said he did to fix his problem.
freelancer75 wrote:1. Update Sound Driver
2. Update Video Driver
3. Downgrade FoF to the next lowest version (This is the version I use)

Hopefully that'll do it and we can chalk one up for the Wiki :)
~Jake2k3

NOTE: If you could work those in reverse order, trying step 3 first, then 2, then 1, and 3 or 2 fixes it, we can pinpoint the problem to just that fix.
Last edited by jake2k3 on Sat Jan 26, 2008 2:46 pm, edited 1 time in total.
Goodbye everyone. It's been fun. I spent many many hours here on these boards and playing/contributing to FoF. Today I uninstalled my game and deleted all my files. I just don't have the time or interest anymore. I won't be coming back here anymore. I might show up in the IRC from time to time to chat. I regret nothing.

So long, farewell.
~Jake2k3
xbox360922
Member
Posts: 1264
Joined: September 15th, 2007
Location: The Milky Way Galaxy
Reputation: 0
Contact:

Postby xbox360922 » Wed Jan 30, 2008 7:24 pm

This error: "AttributeError: GameEngine instance has no attribute 'cmdPlay'"
Has been added to the wiki.
Shredder
jake2k3
Member
Posts: 2801
Joined: February 24th, 2007
Location: River City, Alabama
Reputation: 0

Postby jake2k3 » Thu Jan 31, 2008 11:05 pm

Thanks xbawks.

Error removed from list,
~Jake2k3
Goodbye everyone. It's been fun. I spent many many hours here on these boards and playing/contributing to FoF. Today I uninstalled my game and deleted all my files. I just don't have the time or interest anymore. I won't be coming back here anymore. I might show up in the IRC from time to time to chat. I regret nothing.

So long, farewell.
~Jake2k3
kragoth
Member
Posts: 2
Joined: September 20th, 2007
Location: Shredderland
Reputation: 0

Postby kragoth » Tue Feb 05, 2008 7:29 pm

Hey i got one bug that i didnt find here, and i also found a way to repair it.

Traceback (most recent call last):
File "GameEngine.pyo", line 377, in run
File "GameEngine.pyo", line 369, in main
File "View.pyo", line 208, in render
File "Dialogs.pyo", line 737, in render
IndexError: list index out of range


It appeared when choosing songs in GH3 mod, i selected a dot or a line i don't really know what that was, game crashed. Next time i ran it and selected "play a game" (or whatever it is in game menu) it didn't give me the song list, and crashed like previously. now for the solution:
1. Open fretsonfire.ini
2. Under [Game] find selected_song
3. Clear the content of it so it looks like:

selected_song = <do not put anything here especially this line>

4. Save and rejoice because it works again. :D

Thought I'd share it with you, since i found a lot of help on these forums. Hope it does some good :D
Last edited by kragoth on Tue Feb 05, 2008 7:31 pm, edited 1 time in total.
Shredder
jake2k3
Member
Posts: 2801
Joined: February 24th, 2007
Location: River City, Alabama
Reputation: 0

Postby jake2k3 » Wed Feb 06, 2008 4:46 pm

Thanks for your help kragoth. We already had a page on the wiki for IndexError: list index out of range, but the method you provided is still helpful and has been added.
~Jake2k3
Goodbye everyone. It's been fun. I spent many many hours here on these boards and playing/contributing to FoF. Today I uninstalled my game and deleted all my files. I just don't have the time or interest anymore. I won't be coming back here anymore. I might show up in the IRC from time to time to chat. I regret nothing.

So long, farewell.
~Jake2k3

Return to “Tech Support”

Who is online

Users browsing this forum: No registered users and 6 guests